On this page

Obsolete Pub Features

As of Dart 2, pub no longer supports pub build, pub serve, or transformers. They’re replaced by the build system, which includes the build_runner tool.

For information about building and serving apps in Dart 2, see the following:

If you use Dart 1.x for web development, see the following:

If you maintain a transformer, see the following:

For help in switching from Dart 1.x to Dart 2, see the Dart 2 migration guides: